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Video in Logger Pro  
There are many ways to create and use video clips and still images in Logger Pro.  

• Insert an existing video clip into a Logger Pro experiment. Supported file formats include 
.avi and .mov. Any video file that can be opened by QuickTime can be inserted into 
Logger Pro. 

• Capture a video clip using a digital still camera. Many still cameras include a video 
mode, and these videos can be of quite high quality, as well as potentially high frame 
rate. Transfer the video to your computer via USB or SD card. 

• Record a video clip from an attached web camera or Digital Video (DV) camera directly 
into Logger Pro. This process is called video capture. 

• Take a still image from an attached web camera or DV camera. 

• Insert an existing or captured video clip that shows a sensor-based experiment in 
progress. Note that this mode uses both a video and sensor data. The clip can be 
synchronized to the sensor data after the clip is inserted. When the video and data are 
replayed, the rate can be adjusted as appropriate. Examine mode will highlight the data 
and jump the video to the corresponding frame. An example of this usage is a video of a 
dancer jumping on a Force Plate, with force sensor data recorded in Logger Pro. On 
synchronized playback, the graph will draw as the video plays. This process is called 
synchronized video and sensor data playback. 

• Insert an existing or captured video that does not have corresponding sensor data. Video 
analysis tools allow you to track multiple objects, frame by frame, and extract X and Y 
position data as a function of time for those objects. For example, you might track the 
flight of a basketball in two dimensions. This process is called video analysis.  

• Insert an existing still image to illustrate an experimental setup. Supported file formats 
include .jpg, .gif and .bmp. Any image file that can be opened by QuickTime can be 
inserted into Logger Pro.  

• Insert an existing or captured still image for image (or photo) analysis. Analysis of a still 
image is similar to video analysis, but all the marked points are on a single frame. For 
example, the mathematical form of a catenary curve can be studied from a photo of the 
St. Louis arch. Points are marked along the edge of the arch, which are then plotted in 
Logger Pro for analysis. This process is called photo analysis. 

In these notes we will look at several of these common uses of video in Logger Pro: video 
analysis, synchronized video and sensor playback, and video capture. The first two examples will 
make use of existing videos, and the last example will discuss collecting your own videos for 
analysis or synchronization. 
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Video Analysis 
You can use the Video Analysis tool to create a graphical representation of the motion you see in 
a movie or picture1. This is ideal for mathematically analyzing real-world events.  

A tutorial covering video analysis is available. Select Open from the File menu, and open 
12-Video Analysis in the Tutorials folder. Follow that tutorial to try video analysis yourself. The 
discussion below explains some of the functions available to you. 

After you insert or capture a movie, you can 
open the Video Analysis toolbar. The motion 
that you mark directly on the movie will be 
displayed on a linked graph. After the desired 
range of motion has been graphed, you can 
use Logger Pro’s analysis features to study the 
plotted data.  

Movie Buttons  There are five buttons in the 
bottom left corner of the movie object shown 
here. The button farthest on the left is the Play 
button. Click it to play the movie. The next 
button to the right is the Stop button. It will 
stop the movie during replay. The third button 
resets the video to the beginning. The next two 
buttons move the video to the previous or next 
frame.  

Click  in the bottom right corner of the movie object to display the Video Analysis Toolbar. 
A graph will also be displayed. A new set of X and Y columns will be added.  

Video Analysis Toolbar Buttons 

 

Select Point Highlight a trace point in the movie object. This mode is for editing existing 
points. Once a point is selected, it will be highlighted. Highlighted points can be deleted or 
moved. Move the point using the mouse or by nudging with the cursor keys.  

 

Add Point Enters the mode for marking the location of an object in a frame. Click this 
button, and then click on the object location in the movie. The movie will advance one 
frame; continue marking the object as desired. The frame time, as well as the X and Y 
location of the point is recorded in the data table.  

 

Set Origin Click this button, and then click on the movie to set the location of the origin. If 
needed, this coordinate system can be rotated by dragging the yellow dot on the horizontal 
axis.  

                                                
1 Instead of marking one object across frames (time) as you would in a movie, analysis of a picture allows you to 
mark many points on one frame. This is useful in getting the points along a curve, for example.  
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Set Scale  When you mark points on the movie, the 
program initially records the coordinates of each point 
in screen pixels. Setting the scale allows you to convert 
those coordinates to a physical measurement, e.g. 
meters. In the example shown above, a meter stick 
appears in the same plane as the motion. That meter 
stick can be used to set the scale. Click this button, and 
then drag across an object of known length in your movie. Record that distance in the 
resulting Scale dialog. Note that the reference scale object must be in the same plane as the 
motion, or parallax error will create proportional scaling errors. 

 

Photo Distance  Use this tool to measure a distance on the video after setting the scale. 
This is essentially the inverse function to setting scale; you draw a line on the video, and 
Logger Pro provides the distance.  

 

Set Active  Adds new point series for tracking additional objects, and selects between 
existing series. If a series has not been used before, the button adds new x,y columns and 
creates a new series to track a new object. The active point set is indicated in the popup 
menu. If there are two or more point series, use the menu to create a center of mass 
calculation. You can assign each tracked object a mass, and then Logger Pro will find the 
location of the center of mass of the objects in each frame. The CoM can then be plotted on 
the video, and graphed or used in other calculations.  

 
Toggle Trail  Displays or hides all the points that have been added up to the current time.  

 

Show Origin: Display the origin on the movie object. Click again to remove the origin. 
The origin is set with the Set Origin button 

 
Show Scale: This will show the line that was used when setting the scale (see Set Scale).  

Movie Options 
A number of important settings are found in the 
Movie Options dialog, accessible either by 
selecting the video and choosing Movie Options 
from the Options menu, or by double-clicking 
the movie when not in add point mode.  
 
Of particular note are the options to:  

• Override the frame rate when the video is 
not marked with the correct frame rate. 

• Set the time associated with the First VA 
point to zero. This option will “start the 
clock” at the first marked frame, 
regardless of the time stamp on the 
frame.  
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• Alter the number of frames advanced after marking a point. This allows one to quickly 
mark, say, every fifth frame. 

Synchronzied Video and Sensor Data Playback  
Synchronized video and sensor data playback is useful in understanding just what happened in an 
experiment, especially if the experiment takes place very quickly or very slowly. The video and 
data can be played back at a rate that allows study, and the Logger Pro Examine mode will show 
the video frame that matches a given location on 
the graph. 

A good example is the Ball Toss movie. Open the 
file Ball Toss found in the Sample Movies/Ball 
Toss folder. Click the Start button in the Replay 
control. Notice how the video and graphs play 
together, but it is hard to see the action as the toss 
is so brief.  

Use the Speed slider bar in the Replay control to 
set a playback speed of about 0.25. Now click 
Start again, and note how both the movie and 
graph play back together and at quarter speed.  

Click the Examine button in the toolbar (or choose Examine from the Analyze menu) and move 
the mouse over the position graph. Note that as you move the cursor across the position graph, 
the video frame of the corresponding moment is displayed. 

In this example the video has already been synchronized with the sensor data. This 
synchronization is done easily by identifying a single time in the video that corresponds to a 
single time in the data. Sometimes this is done using the science of the experiment (e.g., the ball is 
at the top of the motion when the position graph is maximum) and sometimes it is done using an 
event other than the science (e.g., observing a finger tap on a force sensor before running a 
collision experiment).  

If the video is captured directly into Logger 
Pro as the sensor data are collected, little 
sync adjustment will be required. 

As an example, you can re-sync the ball toss 
video and data. (You may choose to 
intentionally do it incorrectly to see that 
you’re making a change, and then to fix it.) 
We will start with the case of a video already 
inserted into Logger Pro, and sensor data 
already collected. Only the sync needs to be 
established.  

You’ll need to find an event that is 
identifiable in both the video and the sensor 
data. Once you  have chosen that event, 
perform these steps.  
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1. Click the  (Sync) button. The Movie Synchronization dialog will open.  

2. Click on the graph feature that represents the data event you have chosen for 
synchronization. 

3. Use the slider and the next frame/previous frame buttons to find the frame in the movie 
that corresponds with the event you identified in the graph. 

4. Click . 

If the Replay control is not already open, choose Replay from the Analyze menu to display it. 
Enter an altered playback rate if desired. Click Start to play the movie and data together.  

Video Sources 
There are three primary sources of videos for use in Logger Pro: existing videos found from 
other sources, videos collected from cameras that produce computer-readable files, and capture 
of a video stream from a camera by Logger Pro.  

Existing videos can be found in many places online. If a video can be played in QuickTime, it 
can be inserted in Logger Pro. Sometimes a video must be converted to a different format before 
it can be read by QuickTime. For example, one must convert a YouTube video to a QuickTime-
compatible format before use in Logger Pro.  

Most modern digital still cameras include a video mode. Especially if the camera allows you to 
select a fast shutter speed, these cameras can produce some of the best videos for analysis. 
Transfer the video to your computer by USB from the camera, or by reading the storage card 
(often an SD card) from the computer.  

Some cameras are designed to stream video by firewire or USB.  Logger Pro can capture this 
video stream, even while collecting data, which creates unique data and video collection 
opportunities. However, it is harder to find an appropriate camera for video capture.  

Not all video sources are useful. Many inexpensive video cameras, such as the now-discontinued 
Flip cameras, use a rolling shutter, which introduces temporal distortion that renders the video 
difficult to use for analysis. Wiki “rolling shutter” for more information. Some video cameras 
create proprietary output file formats that cannot be read by Logger Pro or QuickTime.  

Video Capture 

Logger Pro can capture video directly from a video input such as a digital video camera or web 
camera. It is difficult to recommend particular consumer cameras since they change so rapidly. 

Cameras for Video Capture: 

1. A consumer-grade DV (digital video) camera with a firewire video output, such as a 
Sony DCR-HC62. DV cameras offer the best video quality, and many offer the ability to 
adjust the shutter speed to avoid blurring of fast-moving objects. Unfortunately these 
cameras have become rare. 

2. Web cameras that are built-in or can stream over USB offer easy capture but may suffer 
from dropped frames or low image quality.  

3. ProScope  
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4. iPad, cell phone, or similar cameras.  
 
Video capture may work with many other USB or firewire cameras; however Logger Pro has not 
been tested with them. 

Digital still cameras that can collect videos cannot capture video under the control of Logger Pro. 
Instead, the video must be collected using the camera’s controls and transferred from the camera 
as a file. The resulting videos can be of excellent quality. 

Quick Start Instructions to Capture a Video 

1. Before you attempt to capture video, you need to install any drivers or software that come 
with your camera. Verify that you can see video using the manufacturer's software. Do 
not continue until this software functions, but exit that software before continuing. 

2. Connect the camera to the computer, if not already connected. 

3. Launch Logger Pro. Choose Video Capture from the Insert menu. If a camera is detected, 
the Video Capture dialog box will appear, and it will display an active video feed from 
the camera. If you do not see the live video feed, click the set up camera button and 
configure your camera.  

4. You are now ready to capture video in one of two modes. One mode is to collect the 
video by itself. The other mode is to capture a video while simultaneously collecting data 
with sensors. Each method is described 
below.  

Video Capture Only 

Logger Pro will capture video with or without 
sensor data. Follow these instructions for video 
without data. 

  Complete the Quick Start Instructions 
above.  

1. The Video Capture dialog box will 
show live video. Click the Options 
button in the Video Capture dialog box 
to choose the Video Capture Only 
mode. Set your desired capture 
duration. Long captures that are not 
time-lapse will create very large files.  

2. Click the Start Capture button to capture video. You can let the capture run for the 
allotted time or click the Stop Capture button.  

3. At the end of the capture, a movie object for the capture will appear on the Logger Pro 
main window. If you capture additional videos, they will also appear on the Logger Pro 
main window.  

4. To save the movie or movies, choose Save from the File menu. Choose the appropriate 
folder and give your Logger Pro file a name. The movie(s) will be saved with your 
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Logger Pro file and in the same directory as the Logger Pro file. If you have not changed 
any Advanced Settings the video files will be named sequentially, MovieCapture1, 
MovieCapture2, etc.  

Video Capture While Simultaneously Collecting Data 
 

Complete the Quick Start Instructions shown above. Complete any sensor configuration 
needed, including data collection rate and time. 

1. The Video Capture dialog box will show live video. Click the Options button to open the 
Video Capture Options dialog.  

2. Choose the Video Capture Synchronized with Sensor Data Collection option.  

3. If data collection will run more than 10 to 15 seconds, you may want to capture a time-
lapse movie to avoid creating a very large video file. To enable this mode, click the Time 
Lapse Mode option, and choose how often an image should be collected.  

4. Click .  

5. Click the Start Capture or Start Time Lapse button to start video capture and data 
collection together.  

6. At the end of the capture, a movie object for the capture will appear on the Logger Pro 
main window. 

7. To save the movie or movies, choose Save from the File menu. Choose the appropriate 
folder and give your Logger Pro file a name. The movie(s) will be saved with your 
Logger Pro file and in the same directory as the Logger Pro file. If you have not changed 
any Advanced Settings the video files will be named sequentially, MovieCapture1, 
MovieCapture2, etc.  

Take Photo 

You can take a snapshot, treated as a picture in JPEG format, from your movie by clicking the 
Take Photo button. 

Video and Data Synchronization Detail 

Logger Pro will allow you to set a characteristic delay between video and data streams so that 
subsequently collected videos will not require additional synchronization.  

There is a delay between the moment you click the Capture or  buttons in Logger Pro and 
when data collection actually start. Similarly, there is a delay before video capture actually starts. 
These two delay times are different, and depend on the hardware being used. In addition, there is 
some run to run variation in these times (jitter) but the variation is typically much smaller than 
the difference between the two delay times.  

As a result you can sync one collected video with its sensor data, and use that relative delay time 
to set up subsequent video capture with data collection runs. To the extent that the jitter is small, 
the subsequent runs will not require additional synchronization.  
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To set this characteristic delay time, collect video and data, and sync them as before. However, 
before dismissing the Movie Synchronization dialog box, check the box titled “Use this 
Synchronization In Video Capture.” Subsequent video and data runs taken will be set with this 
sync value automatically. 


